Community Forums

Share:

[Solved] Windows 10 Bluetooth Connection Issues with Javad Triumph-1  


Scott Macklyn
Posts: 3
Member
(@scott-macklyn)
FNG
Joined: 3 years ago

Hi everyone,

Not sure if this has been asked before, but I have scoured through countless forum posts and found nothing.

We recently upgraded to a Trimble TSC7 that runs Windows 10. Access runs fine connecting to the internal radio for total station use.

We also run Carlson SurvPC for use with some Javad Triumph-1's we have. This is where the issue arises.

Windows will find the Bluetooth Device (Triumph-1) and pair to it. But then using SurvPC, you can't connect to the GPS unit. I have tried on the TSC7 and a laptop running Win10 also.

Strategies tried:

1. When using SurvPC, the connection is via Generic Bluetooth and select the COM Port relating to the GPS BT to Serial Driver. (I did this by installing Toshiba BT Stack and got a connection to the Unit. Alas its not a Toshiba Laptop and told me evaluation had ended.) But once you get an error, the BT won't automatically connect within range.

2. External BT Adapter. Plugged in a USB dongle and uninstalled/installed those driver for that particular dongle and disbaled internal BT. Will pair but can't connect through SurvPC.

Sometimes the connections erros say "Error 10051 (which from what I gather is a networking issue??)" or that the COM port is inaccessible/not available (I have changed COM port numbers many times to check this). I have also check Bleutooth Services in the Services Manager and made sure they are running/enabled.

Unsure on what I need to do to make this work. It seems that a driver of some sort is needed for the Triumph to make a full connection?

Has anyone else encountered these issues or is it a simple fix that I need to look at? Drivers for the internal device have been updated and windows is at its latest update also.

Thanks, Scott.

2 Replies
JERRY ATTRICK
Posts: 197
Member
(@jerry-attrick)
100+ posts
Joined: 8 years ago

Scott,

I had many issues getting my Carlson RT3 to connect to my Triumph-2 unit, when I made the jump to Version 6 of SurvPC.

Carlson is very aware of the process, I am sure. I contacted them and they put me in touch with a consultant in my region that was very helpful.

I needed software and firmware updates on all of the pieces, i.e. the T-2, SurvPC and the RT3 tablet OS and blue-tooth drivers. Quite a bit of effort. I tried mucking around with the assigning odd serial ports and generic bluetooth, but in the end the updates mentioned made the difference.

Once completed the system works as well as advertised. I even tried the "Hybrid" mode with both a total station/prism and the GPS RTK running from the same pole/rod. I can't wait to find an application that will let me use this setup on a real job. I need to rethink the workflow, since I have always done GPS control first and then total station data collection second. 

Old dog, new tricks.

JA, PLS SoCal

 

 

Reply
1 Reply
Scott Macklyn
Member
(@scott-macklyn)
Joined: 3 years ago

FNG
Posts: 3

Hi JA,

Thanks for the response. I seem to have fixed the issue now, for the TSC7 anyway. I did check firmware but one unit needed a reflash of the current stable firmware and the other needed the beta firmware (not sure why??). The main issues were trying to support another colleague off site somewhere via remote means. I have just got him up and running again (finally). Still have the issue of working on one Win10 PC and not the other. Even issues on a Win7 laptop. But got there in the end via very extensive driver searching and configurations (pretty much like you mentioned).

We are lucky as we only drive GPS on SurvPC and Access for our Trimble units. I don't mind it but I am a Trimble man and have the S6 combined with R8-3's.

Goodluck using the Hybrid+ system. I use the similar system in Access and makes doing a GPS resection in the bush easy for those quick sections. Pole ith target and GPS - easy as.

Thanks again,

Scott 

Reply
Default
:)
:d
:wink:
:mrgreen:
:neutral:
:twisted:
:arrow:
:shock:
:???:
:cool:
:evil:
:oops:
:razz:
:roll:
:cry:
:eek:
:lol:
:mad:
:sad:
:!:
:?:
:idea:
:hmm:
:beg:
:whew:
:chuckle:
:silly:
:envy:
:shutmouth: