Community Forums

Share:

Another Civil 3D Question  

Page 1 / 2

BStrand
Posts: 227
Member
(@bstrand)
100+ posts
Joined: 2 years ago

Hopefully there is a simple solution to this.  So I have a bunch of multileaders in my drawing but I need to dview twist the parcel in paperspace to make it look correct.  I DON'T want the multileaders to twist but I can't seem to find a setting or style adjustment to make them read horizontal.  Does anyone know of a solution to this?

 

21 Replies
Cameron Watson PLS
Posts: 459
(@cameron-watson-pls)
250+ posts
Joined: 4 years ago

If you rotate the UCS in your viewport rather than a dview twist you should get the desired result with your multileaders.  They should remain at the same orientation as they were created in model space.

Reply
9 Replies
BStrand
Member
(@bstrand)
Joined: 2 years ago

100+ posts
Posts: 227

@cameron-watson-pls

OK, and that won't alter the coordinates in model space?

Reply
Cameron Watson PLS
(@cameron-watson-pls)
Joined: 4 years ago

250+ posts
Posts: 459

@bstrand

No, you're just changing the UCS of the viewport.  Unlock the viewport, double click into it then command UCS>Z>whatever rotation angle you want>Enter then PLAN>Enter.  

Reply
BStrand
Member
(@bstrand)
Joined: 2 years ago

100+ posts
Posts: 227

@cameron-watson-pls

Strange.  I did this and the multileaders rotated along with the linework exactly like with dview twist.  Maybe I just have a bad setting somewhere.

Reply
Cameron Watson PLS
(@cameron-watson-pls)
Joined: 4 years ago

250+ posts
Posts: 459

@bstrand

Are you using an annotative text style in your multileader style that has the match text orientation to layout box checked?

Reply
BStrand
Member
(@bstrand)
Joined: 2 years ago

100+ posts
Posts: 227

@cameron-watson-pls

The only mention of annotative I see in the style menu is with regard to scaling.  I don't see a checkbox to match a layout.  Maybe a screen clip will help:

Capture

 

Reply
Cameron Watson PLS
(@cameron-watson-pls)
Joined: 4 years ago

250+ posts
Posts: 459

@bstrand

Text Style

Reply
Richard Imrie
Member
(@richard-imrie)
Joined: 4 years ago

1,000+ posts
Posts: 1179

@cameron-watson-pls

I think that works to multitext only, not multitext in a multileader.

We use Civil3D with dview twist and a combination of multileaders and Civil3D labels, the latter orientate to the layout, and the style (dragged state) can be fiddled to look like a multileader.

Reply
BStrand
Member
(@bstrand)
Joined: 2 years ago

100+ posts
Posts: 227

@richard-imrie

I think it's possible to just fiddle with the rotation angle in the properties of each multileader but I was trying to avoid doing that since it seemed tedious and time consuming.  In hindsight I probably should have just started with that.

Anyway, thanks for the help guys.

Reply
Cameron Watson PLS
(@cameron-watson-pls)
Joined: 4 years ago

250+ posts
Posts: 459

@richard-imrie

Yeah, i guess you're right.  The two on the left were created with the match orientation toggle changed and neither rotated when I changed the UCS.  They're both horizontal in model space.  The one on the right was created through the viewport after I rotated the viewport UCS. 

MULTILEADER

 

Reply
BStrand
Posts: 227
Member
(@bstrand)
100+ posts
Joined: 2 years ago

Turns out the solution wasn't so bad.  I did a dview twist for 90 degrees.  Then selected similar on all the multileaders and entered -90 in the rotation box of the properties window and everything flipped back to normal.  Still would be nice to have the software be able to read my mind.

Reply
1 Reply
BlitzkriegBob
Member
(@blitzkriegbob)
Joined: 5 years ago

100+ posts
Posts: 205

@bstrand

I know you've worked your way through this, but I'd like to chime in if you don't mind.  I'm not a fan of using a Dview Twist.  Rather than Cameron's suggestion, I prefer to rotate my viewport in order to get an aligned view that I like.

Old school style, I would use the MVSetup command, with the Align option, and then the Rotate View option.  You need to figure out what your desired rotation is beforehand, and then plug the number in at the command line. FYI, the angle doesn't accumulate.  For example, if you think you need a 45 degree rotation, then realize it should be rotated -45 degrees, just use Rotate View again and plug in -45 rather than -90 degrees.  I say this because I would never get the rotation correct the first time when I did it this way.

New school style, I use the Align Space command in the Express Tools ribbon.  What I do is draw a line in model space on top of whatever line I will want to be straight across in paper space.  Then I get my viewport to the desired scale where it shows the desired line.  I do a Change Space on the line to bring it to paper space.  I rotate that line so that it's straight across.  Then I use the Align Space command to pick the two points on the original object in model space, then the two points in paper space for the new object.  An added bonus is that you can zoom and pan while picking the points in model space, because in the end your scale will set itself back to the original scale.  A second added bonus is no math, and no weird dance moves as you're waving your hand around in the air trying to figure out which way to rotate!

I do it that way because I rarely ever keep north straight up or at 90 degrees.  I'm always at some odd rotation.  Now of course this doesn't solve your original problem with the multileaders.  I actually talked about why I prefer C3D notes in lieu of multileaders in this thread.  One of the points that I made was "You can't match the layout orientation with a multileader."  Unless, of course, you're rotating all your multileaders, which to me is just more work.

Reply
ekillo
Posts: 455
Member
(@ekillo)
250+ posts
Joined: 9 years ago

Since you got you question answered, I will try one about Civil3D 2019.  I usually use running osnaps endpoint and node most of the time and turn them off and on with F3.  My question is what would continually cause them to clear and have to be reset?  I know that in old autocad if you did not exit out of a routine correctly then the osnap setting pre-routine would not be reset, but that does not seem to be the case here.  I can be working normal on a drawing and start a line command and the osnap will not be set, this is aggravating as this is the way I have always done things, but sometimes I will just shift right-click and get the osnap that I need.

 

One other question:

Several versions back the ability to press the shift key to alter the function of trim or extend to the other function was added, in my Civil 3D it may show the red X and show what is supposed to happen, but it will not trim by pressing shift  when using the extend command.  Anyone know what maybe causing this?

TIA

Ed

Reply
1 Reply
BStrand
Member
(@bstrand)
Joined: 2 years ago

100+ posts
Posts: 227
Posted by: @ekillo

I usually use running osnaps endpoint and node most of the time and turn them off and on with F3.  My question is what would continually cause them to clear and have to be reset? 

Yeah, this is quite annoying and another thing I would have probably asked about eventually.  I haven't found a solution to it but I haven't looked all that much either since I don't run into it often.

Reply
ekillo
Posts: 455
Member
(@ekillo)
250+ posts
Joined: 9 years ago

BUMP

Reply
Page 1 / 2
Default
:)
:d
:wink:
:mrgreen:
:neutral:
:twisted:
:arrow:
:shock:
:???:
:cool:
:evil:
:oops:
:razz:
:roll:
:cry:
:eek:
:lol:
:mad:
:sad:
:!:
:?:
:idea:
:hmm:
:beg:
:whew:
:chuckle:
:silly:
:envy:
:shutmouth: